你现在的位置:首页-技术文献-其他-Flash Player怎么安装无广告原版

Flash Player怎么安装无广告原版

2022-06-07 16:36:11 来源:系统总裁 作者:sysceo 阅读:4296

Adobe Flash Player

Adobe Flash Player

  • 发布时间:2022-07-13
  • 大小:19.69MB
  • 版本:26.0.0.151

之前一直认为Flash Player 29.0.0.171好用,最近却发现会提示“版本过旧、需要升级”而用不了。花了点时间测试,终于找到好用的原版,推荐26.0.0.151,因为27.0.0.130ActiveX版在Win7下测试偶尔有问题,为什么是这个版本?找了一下历史新闻,原来Adode在2017年7月26日就宣布了Flash Player将于2020年底停止服务,而26.0.0.151及27.0.0.130正好是分别于2017年7月和8月开发的。


安装说明:


1、关于安装文件:_win后缀的是NPAPI火狐版插件,_winax是XP/Win7版IE(ActiveX)插件,_winpep是PPAPI谷歌版插件。


2、先卸载旧版插件再安装:除Win10 ActiveX版外,建议卸载旧版后,用官方uninstall工具再清理一下,然后重启系统,再安装。注意PPAPI版插件除了系统目录外,浏览器相关PepperFlash目录下可能也有,也要删除或替换。另外,最好把残留的settings.sol配置文件也删除,PPAPI版这个文件在Pepper Data目录下找,ActiveX和NPAPI版在%APPDATA%\Macromedia\Flash Player\子目录下找。


3、如果安装时提示不是最新版本,定位到以下注册表项,把其中大于25.0的键值都删除后再安装:

[HKEY_LOCAL_MACHINE\SOFTWARE\Macromedia\FlashPlayer\SafeVersions]

[HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Macromedia\FlashPlayer\SafeVersions]


4、安装好后根据不同的浏览器作简单设置:


A、IE11/旧版Edge:编辑文本文件%LOCALAPPDATA%\Microsoft\Internet Explorer\VersionManager\versionlist.xml,注释掉Flash数据段;或者通过组策略禁用阻止过期控件功能:[用户配置->管理模板->Windows 组件->Internet Explorer->安全功能->加载项管理->关闭 Internet Explorer 的过时 ActiveX 控件的阻止功能]设置为“已启用”。


B、Chrome/新版Edge/百分浏览器:Chrome/Edge须使用v87之前版本,并把插件版本号修改为大于32.0.0.465。PPAPI版插件的版本号修改很简单,插件所在目录带版本号的就修改目录名,目录不带版本号的就编辑文本文件manifest.json。


C、Firefox:使用Fx84之前版本即可,不用作其他修改。


一般以上设置就可以了,官方原版,用着放心,也不用频繁更新。如果使用IE/火狐,又碰到某些网站对插件版本号有要求,这时就需要修改.ocx/.dll文件版本号了,网上有教程,在此不赘述。


目前对Flash的限制几乎是全方位的,包括操作系统、浏览器、插件自身、网站4个层面


下面大概说一下有关限制和应对方法:


一、系统层面:Win10系统更新补丁kb4577586会强制删除Flash插件,这个就只有想办法不安装该更新了。


二、浏览器层面:


1、IE11和旧版Edge的限制:通过版本列表来阻止低版本Flash运行,目前版本号小于等于32.0.0.386的都会被阻止运行。


解决办法有4个,选哪个都可以,推荐前两个:


A、编辑文件:%LOCALAPPDATA%\Microsoft\Internet Explorer\VersionManager\versionlist.xml,注释掉Flash相关数据段。


注释掉Flash相关数据段


B、组策略禁用阻止过期控件功能:[用户配置->管理模板->Windows 组件->Internet Explorer->安全功能->加载项管理->关闭 Internet Explorer 的过时 ActiveX 控件的阻止功能]设置为“已启用”。


C、把相关网站加入受信任的站点。


D、提高FP版本号(修改.ocx文件版本号)。


2、Firefox的限制:一是运行Flash需手工确认,二是从Fx85起不支持Flash。


解决办法:使用Fx84(如果要自动运行Flash那还得更早的火狐版本)。


3、Chrome/新版Edge的限制:一是对FP32.0.0.465及之前的版本直接阻止,无法运行;二是对FP版本号大于32.0.0.465的也需要手工允许;三是从v88起浏览器不支持Flash。


解决办法:浏览器使用v87(如果要自动运行Flash那还得更早的版本)、或者使用百分浏览器,并提高FP版本号(PPAPI版修改很简单,插件所在目录带版本号的就修改目录名,目录不带版本号的就编辑manifest.json,比如把其中的26.0.0.151修改为66.0.0.151)。


66.0.0.151


三、Flash插件自身的限制:一是从v30起限制中国区用户不能使用国际版;二是v32.0.0.387之后的版本含有时间“炸弹”,2021年1月12日起会提示EOL生命期终止而无法使用;三是v27.0.0.159之后的版本含有限制旧版的暗桩,最近开始会提示“版本过旧、需要升级”而不能使用。


解决办法:使用27.0.0.130及之前的版本(推荐26.0.0.151);或者是在v32等版本的基础上去除相关限制(需修改.ocx/.dll文件)。


四、网站层面:有些网站会对FP插件版本号有要求,碰到这种就只好修改、提高版本号了(通过以上所说的修改manifest.json文件、修改插件所在目录的文件夹名称、直接修改.ocx/.dll等方式)。


以上就是Flash Player怎么安装无广告原版文章,更多教程请关注系统总裁


相关推荐
win7安装adobe flash player权限不足
如何禁止掉 Flash Player自动更新
Flash Player怎么安装无广告原版